[infinispan-dev] Kubernetes simple demo failing with OpenShift 3.7.2 and latest FMP

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[infinispan-dev] Kubernetes simple demo failing with OpenShift 3.7.2 and latest FMP

Galder Zamarreno
Hey Sebastian,

I'm trying to update simple tutorials to Infinispan 9.2.2.Final but Kubernetes demo does not seem to be working.

I've started OpenShift 3.7.2 and have updated FMP to 3.5.33 and build fails. Error is:

> error: build error: image "java:8-jre-alpine" must specify a user that is numeric and within the range of allowed users

Cheers,
Galder

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
Reply | Threaded
Open this post in threaded view
|

Re: [infinispan-dev] Kubernetes simple demo failing with OpenShift 3.7.2 and latest FMP

Galder Zamarreno
Hey Sebastian,

I've been checking with Clement and this might be due to OpenShift not allowing that base image for source builds.

It seems like that to do S2I you need a base image with a certain user (I think that's 1001) and neither the java/ nor the fabric8/ ones do that. Clement mentioned redhat-openjdk-18/openjdk18-openshift images might do that but those I think are behind VPN or require some for of login. Clement also mentioned this might work with minishift, but I've not tried yet.

The alternative might be to switch that example to use binary builds and adjust instructions for OpenShift and plain Kubernetes.

Cheers,
Galder

On Thu, May 3, 2018 at 6:49 PM Galder Zamarreno <[hidden email]> wrote:
Hey Sebastian,

I'm trying to update simple tutorials to Infinispan 9.2.2.Final but Kubernetes demo does not seem to be working.

I've started OpenShift 3.7.2 and have updated FMP to 3.5.33 and build fails. Error is:

> error: build error: image "java:8-jre-alpine" must specify a user that is numeric and within the range of allowed users

Cheers,
Galder

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
Reply | Threaded
Open this post in threaded view
|

Re: [infinispan-dev] Kubernetes simple demo failing with OpenShift 3.7.2 and latest FMP

Radim Vansa
I think you can override this limitation using

|oc adm policy add-scc-to-user anyuid developer |

though it'd not be a recommended setting for production use...

R.



On 05/04/2018 09:45 AM, Galder Zamarreno wrote:

> Hey Sebastian,
>
> I've been checking with Clement and this might be due to OpenShift not
> allowing that base image for source builds.
>
> It seems like that to do S2I you need a base image with a certain user
> (I think that's 1001) and neither the java/ nor the fabric8/ ones do
> that. Clement mentioned redhat-openjdk-18/openjdk18-openshift images
> might do that but those I think are behind VPN or require some for of
> login. Clement also mentioned this might work with minishift, but I've
> not tried yet.
>
> The alternative might be to switch that example to use binary builds
> and adjust instructions for OpenShift and plain Kubernetes.
>
> Cheers,
> Galder
>
> On Thu, May 3, 2018 at 6:49 PM Galder Zamarreno <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hey Sebastian,
>
>     I'm trying to update simple tutorials to Infinispan 9.2.2.Final
>     but Kubernetes demo does not seem to be working.
>
>     I've started OpenShift 3.7.2 and have updated FMP to 3.5.33 and
>     build fails. Error is:
>
>     > error: build error: image "java:8-jre-alpine" must specify a
>     user that is numeric and within the range of allowed users
>
>     Cheers,
>     Galder
>
>
>
> _______________________________________________
> infinispan-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/infinispan-dev


--
Radim Vansa <[hidden email]>
JBoss Performance Team

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
Reply | Threaded
Open this post in threaded view
|

Re: [infinispan-dev] Kubernetes simple demo failing with OpenShift 3.7.2 and latest FMP

Galder Zamarreno
Still same error after applying that to developer

On Fri, May 4, 2018 at 10:18 AM Radim Vansa <[hidden email]> wrote:
I think you can override this limitation using

|oc adm policy add-scc-to-user anyuid developer |

though it'd not be a recommended setting for production use...

R.



On 05/04/2018 09:45 AM, Galder Zamarreno wrote:
> Hey Sebastian,
>
> I've been checking with Clement and this might be due to OpenShift not
> allowing that base image for source builds.
>
> It seems like that to do S2I you need a base image with a certain user
> (I think that's 1001) and neither the java/ nor the fabric8/ ones do
> that. Clement mentioned redhat-openjdk-18/openjdk18-openshift images
> might do that but those I think are behind VPN or require some for of
> login. Clement also mentioned this might work with minishift, but I've
> not tried yet.
>
> The alternative might be to switch that example to use binary builds
> and adjust instructions for OpenShift and plain Kubernetes.
>
> Cheers,
> Galder
>
> On Thu, May 3, 2018 at 6:49 PM Galder Zamarreno <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hey Sebastian,
>
>     I'm trying to update simple tutorials to Infinispan 9.2.2.Final
>     but Kubernetes demo does not seem to be working.
>
>     I've started OpenShift 3.7.2 and have updated FMP to 3.5.33 and
>     build fails. Error is:
>
>     > error: build error: image "java:8-jre-alpine" must specify a
>     user that is numeric and within the range of allowed users
>
>     Cheers,
>     Galder
>
>
>
> _______________________________________________
> infinispan-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/infinispan-dev


--
Radim Vansa <[hidden email]>
JBoss Performance Team

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
Reply | Threaded
Open this post in threaded view
|

Re: [infinispan-dev] Kubernetes simple demo failing with OpenShift 3.7.2 and latest FMP

Sebastian Laskawiec
Have you tried my latest PR, which has been waiting for the review for over 2 months :D


On Fri, May 4, 2018 at 4:35 PM Galder Zamarreno <[hidden email]> wrote:
Still same error after applying that to developer

On Fri, May 4, 2018 at 10:18 AM Radim Vansa <[hidden email]> wrote:
I think you can override this limitation using

|oc adm policy add-scc-to-user anyuid developer |

though it'd not be a recommended setting for production use...

R.



On 05/04/2018 09:45 AM, Galder Zamarreno wrote:
> Hey Sebastian,
>
> I've been checking with Clement and this might be due to OpenShift not
> allowing that base image for source builds.
>
> It seems like that to do S2I you need a base image with a certain user
> (I think that's 1001) and neither the java/ nor the fabric8/ ones do
> that. Clement mentioned redhat-openjdk-18/openjdk18-openshift images
> might do that but those I think are behind VPN or require some for of
> login. Clement also mentioned this might work with minishift, but I've
> not tried yet.
>
> The alternative might be to switch that example to use binary builds
> and adjust instructions for OpenShift and plain Kubernetes.
>
> Cheers,
> Galder
>
> On Thu, May 3, 2018 at 6:49 PM Galder Zamarreno <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hey Sebastian,
>
>     I'm trying to update simple tutorials to Infinispan 9.2.2.Final
>     but Kubernetes demo does not seem to be working.
>
>     I've started OpenShift 3.7.2 and have updated FMP to 3.5.33 and
>     build fails. Error is:
>
>     > error: build error: image "java:8-jre-alpine" must specify a
>     user that is numeric and within the range of allowed users
>
>     Cheers,
>     Galder
>
>
>
> _______________________________________________
> infinispan-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/infinispan-dev


--
Radim Vansa <[hidden email]>
JBoss Performance Team

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
Reply | Threaded
Open this post in threaded view
|

Re: [infinispan-dev] Kubernetes simple demo failing with OpenShift 3.7.2 and latest FMP

Galder Zamarreno
Integrated!
On Sun, 6 May 2018 at 15:47, Sebastian Laskawiec <[hidden email]> wrote:
Have you tried my latest PR, which has been waiting for the review for over 2 months :D


On Fri, May 4, 2018 at 4:35 PM Galder Zamarreno <[hidden email]> wrote:
Still same error after applying that to developer

On Fri, May 4, 2018 at 10:18 AM Radim Vansa <[hidden email]> wrote:
I think you can override this limitation using

|oc adm policy add-scc-to-user anyuid developer |

though it'd not be a recommended setting for production use...

R.



On 05/04/2018 09:45 AM, Galder Zamarreno wrote:
> Hey Sebastian,
>
> I've been checking with Clement and this might be due to OpenShift not
> allowing that base image for source builds.
>
> It seems like that to do S2I you need a base image with a certain user
> (I think that's 1001) and neither the java/ nor the fabric8/ ones do
> that. Clement mentioned redhat-openjdk-18/openjdk18-openshift images
> might do that but those I think are behind VPN or require some for of
> login. Clement also mentioned this might work with minishift, but I've
> not tried yet.
>
> The alternative might be to switch that example to use binary builds
> and adjust instructions for OpenShift and plain Kubernetes.
>
> Cheers,
> Galder
>
> On Thu, May 3, 2018 at 6:49 PM Galder Zamarreno <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hey Sebastian,
>
>     I'm trying to update simple tutorials to Infinispan 9.2.2.Final
>     but Kubernetes demo does not seem to be working.
>
>     I've started OpenShift 3.7.2 and have updated FMP to 3.5.33 and
>     build fails. Error is:
>
>     > error: build error: image "java:8-jre-alpine" must specify a
>     user that is numeric and within the range of allowed users
>
>     Cheers,
>     Galder
>
>
>
> _______________________________________________
> infinispan-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/infinispan-dev


--
Radim Vansa <[hidden email]>
JBoss Performance Team

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev
_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev

_______________________________________________
infinispan-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/infinispan-dev